doorkeeper
https://github.com/doorkeeper-gem/doorkeeper
Ruby
Doorkeeper is an OAuth 2 provider for Ruby on Rails / Grape.
Triage Issues!
When you volunteer to triage issues, you'll receive an email each day with a link to an open issue that needs help in this project. You'll also receive instructions on how to triage issues.
Triage Docs!
Receive a documented method or class from your favorite GitHub repos in your inbox every day. If you're really pro, receive undocumented methods or classes and supercharge your commit history.
3 Subscribers
Add a CodeTriage badge to doorkeeper
Help out
- Issues
- Enforce a wall-clock timeout and a byte budget on HttpFetcher
- Issue stateless JWT tokens from the client credentials grant
- Allow issuer to be resolved per request, and iss (RFC 9207) to be enabled per application
- Report the granted resources as `aud` when introspecting a refresh token
- Keep refresh tokens bound to every resource of the original grant (RFC 8707 §2.2)
- Accept client ID metadata documents that list none among supported methods
- Refreshing with a narrowed `resource` also narrows the refresh token (RFC 8707)
- Support for Pushed Authorization Requests?
- Persist per-client token endpoint authentication methods on `oauth_applications`
- Add refresh token chain tracking to support grant-level revocation (RFC 7009 §2.1)
- Docs
- SkipValidation::ClassMethods#skip_translation_validation
- SkipValidation::ClassMethods#skip_validation
- SignatureSheetsHelper#example_text_help
- SignatureSheetsHelper#date_of_birth_and_postal_code_text_help
- SignatureSheetsHelper#required_fields_to_verify_text_help
- SignatureSheetsHelper#signable_options
- HasOrders#current_order
- HasOrders#valid_orders
- CommentsController#send_evaluation_notification?
- CommentsController#verify_comments_open!