doorkeeper
https://github.com/doorkeeper-gem/doorkeeper
Ruby
Doorkeeper is an OAuth 2 provider for Ruby on Rails / Grape.
Triage Issues!
When you volunteer to triage issues, you'll receive an email each day with a link to an open issue that needs help in this project. You'll also receive instructions on how to triage issues.
Triage Docs!
Receive a documented method or class from your favorite GitHub repos in your inbox every day. If you're really pro, receive undocumented methods or classes and supercharge your commit history.
3 Subscribers
Add a CodeTriage badge to doorkeeper
Help out
- Issues
- Allow issuer to be resolved per request, and iss (RFC 9207) to be enabled per application
- Docs: Correct the README on pre-migration rows and refresh_token_scopes
- Report the granted resources as `aud` when introspecting a refresh token
- Keep refresh tokens bound to every resource of the original grant (RFC 8707 §2.2)
- Accept client ID metadata documents that list none among supported methods
- Accept client ID metadata documents for public clients
- Refreshing with a narrowed `resource` also narrows the refresh token (RFC 8707)
- Support for Pushed Authorization Requests?
- Persist per-client token endpoint authentication methods on `oauth_applications`
- Add refresh token chain tracking to support grant-level revocation (RFC 7009 §2.1)
- Docs
- CMS::Settings#valid_token?
- CMS::Settings#admin?
- CMS::Settings#render_draft_content?
- CMS::Settings#initialize
- System::Database.adapter_module
- System::Database#adapter_module
- System::Database::Scopes::IdOrSystemName#by_id_or_system_name
- System::Database::Scopes::IdOrSystemName#find_by_id_or_system_name
- System::Database::Scopes::IdOrSystemName#find_by_id_or_system_name!
- System::Database.ready?