doorkeeper
https://github.com/doorkeeper-gem/doorkeeper
Ruby
Doorkeeper is an OAuth 2 provider for Ruby on Rails / Grape.
Triage Issues!
When you volunteer to triage issues, you'll receive an email each day with a link to an open issue that needs help in this project. You'll also receive instructions on how to triage issues.
Triage Docs!
Receive a documented method or class from your favorite GitHub repos in your inbox every day. If you're really pro, receive undocumented methods or classes and supercharge your commit history.
3 Subscribers
Add a CodeTriage badge to doorkeeper
Help out
- Issues
- Allow issuer to be resolved per request, and iss (RFC 9207) to be enabled per application
- Report the granted resources as `aud` when introspecting a refresh token
- Keep refresh tokens bound to every resource of the original grant (RFC 8707 §2.2)
- Refreshing with a narrowed `resource` also narrows the refresh token (RFC 8707)
- Support for Pushed Authorization Requests?
- Persist per-client token endpoint authentication methods on `oauth_applications`
- Add refresh token chain tracking to support grant-level revocation (RFC 7009 §2.1)
- Track refresh token families to revoke a whole refresh chain at once
- Client ID Metadata Documents (CIMDs)
- add dpop (rfc 9449) support
- Docs
- Doorkeeper::Rails::Routes#allow_oob_redirect_uris?
- Doorkeeper::RedirectUriValidator#handled_as_oob_redirect_uri?
- Doorkeeper::AccessTokenMixin#revoke_refresh_token
- Doorkeeper::AccessTokenMixin#refresh_token_revoked?
- Doorkeeper::AccessTokenMixin::ClassMethods#previous_access_token_kept_on_refresh?
- Doorkeeper::AccessTokenMixin::ClassMethods#refresh_token_revoked_at_supported?
- Doorkeeper::AccessTokenMixin::ClassMethods#refresh_token_usable?
- Doorkeeper::OAuth::TokenIntrospection#refresh_token_revoked?
- Doorkeeper::OAuth::RefreshTokenRequest#revoke_refresh_token
- Doorkeeper::OAuth::RefreshTokenRequest#refresh_token_revoked?